Problem LiveUSB

View previous topic View next topic Go down

Problem LiveUSB

Post  frafa on Wed Sep 15, 2010 2:02 am

Hello Smile
on v2.0
-if copy iso on LiveUSB format in fat32 boot option live-media-path=/path.../casper won't run...
Casper can not find the squashfs

-and if possible you install lupin-casper in the ramdisk
same in the official versions of Ubuntu...

http://liveusb.info
frafa

frafa

Number of posts : 3
Registration date : 2010-09-15

View user profile

Back to top Go down

Re: Problem LiveUSB

Post  nannib on Wed Sep 15, 2010 1:49 pm

I don't understand ....you have only to clone the nbcaine2.0 dd image on an usb pendrive...and it'll work...what's wrong?
Thanks Wink
Nanni Bassetti

_________________
-------------------------
Nanni Bassetti
Caine Project Manager
http://www.nannibassetti.com
avatar
nannib
Admin

Number of posts : 271
Age : 47
Registration date : 2008-10-28

View user profile http://www.nannibassetti.com/

Back to top Go down

Re: Problem LiveUSB

Post  frafa on Wed Sep 15, 2010 2:02 pm

Hello
on a multiboot LiveUSB
or it must boot via boot option live-media-path=/path.../casper
by copying the iso in a folder at the root of the USB
and with your casper modified, it does not work

or boot with the boot option iso-scan/filename=/xxx.iso
but this boot option requires that the package lupin-casper
installed in the ramdisk, and it is not the case

I ask this because some users want me to multiboot adds support for multiboot Caine
sorry my English is bad...
Fran├žois

frafa

Number of posts : 3
Registration date : 2010-09-15

View user profile

Back to top Go down

LiveUSB hangs...

Post  j58 on Wed Sep 15, 2010 4:51 pm

Cloned the nbcaine2.0.dd.001 to an USB flash memory stick with dd.
Boots and after the Ubuntu purple screen get thrown back to a minimal shell.

This is the error screen:
-----------------------------------------------------------------------------
BusuBox v1.13.3 (Ubuntu 1:1.13.3-1ubuntu11) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs) mount: mounting /dev/sda5 on /snap-backing failed: invalid argument

-----------------------------------------------------------------------------

Also get boot screen saying:
boot:
After hitting <Enter> get menu with different booting options.

j58

Number of posts : 4
Registration date : 2010-09-15

View user profile

Back to top Go down

Re: Problem LiveUSB

Post  nannib on Wed Sep 15, 2010 7:01 pm

It's strange...because the nbcaine.dd.001 it's the image file of my pendrive and it works perfectly booting from my Samsung NC10 Netbook...did you check the MD5 of the dd file ?
Thanks
bye

_________________
-------------------------
Nanni Bassetti
Caine Project Manager
http://www.nannibassetti.com
avatar
nannib
Admin

Number of posts : 271
Age : 47
Registration date : 2008-10-28

View user profile http://www.nannibassetti.com/

Back to top Go down

Re: Problem LiveUSB

Post  nannib on Thu Sep 16, 2010 8:30 am

Try to download now the NBCaine file (now it's a gz file) and let me know Smile
Thanks

_________________
-------------------------
Nanni Bassetti
Caine Project Manager
http://www.nannibassetti.com
avatar
nannib
Admin

Number of posts : 271
Age : 47
Registration date : 2008-10-28

View user profile http://www.nannibassetti.com/

Back to top Go down

Re: Problem LiveUSB

Post  frafa on Thu Sep 16, 2010 12:54 pm

Hello,
for me and multiboot liveusb if not possible to use dd
method is copy content iso in the folder on usb key
and boot with option ==> live-media-path=/copycontentiso/casper

but if not possible because of your change of script casper the ramdisk
sorry for my bad english...
Francois

frafa

Number of posts : 3
Registration date : 2010-09-15

View user profile

Back to top Go down

Re: Problem LiveUSB

Post  Joeviocoe on Wed Feb 06, 2013 4:10 am

I am using YUMI multiboot to run Caine 3.0 ISO.

The default GRUB boot entry is:
Code:
# Modify the following entry if it does not boot
title Caine 3.0
find --set-root --ignore-floppies --ignore-cd /multiboot/ISOS/caine3.0.iso
map --heads=0 --sectors-per-track=0 /multiboot/ISOS/caine3.0.iso (hd32)
map --hook
chainloader (hd32)

The ISO boots, I get the Graphical CAINE loading screen. But receive this error:
Code:
Busybox v1.18.5 (Ubuntu 1:1.18.5-1ubuntu4) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs) Unable to find a medium containing a live file system


How should I modify the boot commands?
I don't think the NBCaine dd file is what I want, since multiboot is not possible. I need multiboot.

I've heard Casper is to blame, but do I need to alter the ISO file at all?

Thanks.

Joeviocoe

Number of posts : 8
Registration date : 2013-02-06

View user profile

Back to top Go down

Re: Problem LiveUSB

Post  nannib on Sun Feb 10, 2013 11:19 am

You can try NBCaine 4.0 Beta
http://www.caine-live.net/Downloads/nbcaine4.0_b.iso
for your multiboot.
bye

_________________
-------------------------
Nanni Bassetti
Caine Project Manager
http://www.nannibassetti.com
avatar
nannib
Admin

Number of posts : 271
Age : 47
Registration date : 2008-10-28

View user profile http://www.nannibassetti.com/

Back to top Go down

Re: Problem LiveUSB

Post  Joeviocoe on Thu Feb 14, 2013 12:02 am

I am still getting the error with Caine 4.0 beta....

Busybox v1.18.5 (Ubuntu 1:1.18.5-1ubuntu4) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs) Unable to find a medium containing a live file system

I still suspect that I need to add boot commands to the menu.lst of my MultiBoot USB drive.

Joeviocoe

Number of posts : 8
Registration date : 2013-02-06

View user profile

Back to top Go down

Re: Problem LiveUSB

Post  Joeviocoe on Fri Feb 15, 2013 8:06 am

Found a solution here...
http://reboot.pro/topic/17337-yumi-multiboot-usb-boot-blackbuntu-iso-via-grub4dos/

Basically, extracted ISO to its own folder within the 'multiboot' directory that was created with the YUMI multiboot tool when Ubuntu was installed.
And using the above forum topic as a guide. Although it was describing a boot problem with BlackBuntu 0.3... it was the same issue with the same error.
And since Caine is also Ubuntu based... the solution was the same.
*(don't forget to change the .lz file references to .gz also)

Joeviocoe

Number of posts : 8
Registration date : 2013-02-06

View user profile

Back to top Go down

Re: Problem LiveUSB

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum